• 文字サイズ変更
  • S
  • M
  • L

FAQのNo.から検索


  • No : 21139
  • 公開日時 : 2015/03/02 08:14
  • 更新日時 : 2018/04/09 17:00
  • 印刷

【DataSpider Servista】 Salesforceのバージョンアップにより Salesforceアダプタで作成した処理に影響はありますか

Salesforce のバージョンアップ(例:Winter '13 → Spring '14)にともなって、Salesforce アダプタで作成した処理に影響はありますか?
カテゴリー : 

回答

Salesforce アダプタで使用する API のバージョンを変更しなければ、処理への影響はありません。
 
使用する API のバージョンを別のバージョンに変更する場合(例:18.0 → 26.0)にのみ、
動作への影響が生じる可能性があります。
 
 
参考情報
 
salesforce SOAP API 開発者ガイド
 
 
「SOAP API サポートポリシー」の「後方互換性」に、下記の通り記載されています。(2016 年 7 月 13 日現在)
 
プラットフォームソフトウェアのリリース全体で、各SOAP APIバージョンのサポートを維持しています。指定した SOAP API バージョンで機能するよう作成されたアプリケーションが、その後のプラットフォームソフトウェアのリリースでも同じバージョンの SOAP API では継続して機能するという点では、SOAP API には後方互換性があります。
 
Salesforceでは、あるバージョンのSOAP APIに対応して作成されたアプリケーションがその後のSOAP APIバージョンで機能することは保証されません。SOAP API の拡張は継続して行われているため、メソッド署名およびデータ表示の変更が必要になる場合がよくあります。ただし、変更によりアプリケーションを新しいSOAP API バージョンに移行する必要がある場合、バージョン間の SOAP API の一貫性を最小限に保持しています。
 
Winter '07 リリースに付属する SOAP API バージョン 9.0 を使用して作成されたアプリケーションは、Summer'07 リリースの SOAP API バージョン 9.0、また今後のリリースにも引き続き対応します。ただし、同じアプリケーションが SOAP API バージョン 10 で機能するようにするために、アプリケーションを変更する必要がある場合があります。
 

このFAQに関してのご意見をお聞かせ下さい。